Discussion:
Problemi di condivisione in rete con Seven
(too old to reply)
unknown
2010-04-11 17:26:58 UTC
Permalink
Dunque, prima mia figlia aveva W_XP e, con

//192.168.0.2/Condivisa /media/condivisa1 smbfs 0 0

nell'fstab, vedevo la sua cartella Condivisa.

Ora che lei e' passata a W_Seven, quando faccio

smbclient -L 192.168.0.2

che e' il suo indirizzo nella rete domestica, ottengo un

session setup failed: NT_STATUS_LOGON_FAILURE

mentre se lo faccio all'indirizzo del pc di mia moglie che ha ancora
W_XP, vedo le sue cartelle condivise e le posso utilizzare avendo messo
in fstab le righe giuste per poterle acquisire.

Mia figlia dice di non avere firewall attivati sul suo seven.

Qualcuno sa quale novita' sia comparsa in seven per impedire che vengano
lette le cartelle che seven mette in condivisione?

Da seven viene vista invece regolarmente una mia cartella che ho
condiviso, e la stampante collegata al mio pc, condivisa anch'essa.

Insomma, questo seven, che cacchio di casini ha instaurato nelle
connessioni di rete? Funziona tutto cosi' bene con XP, e non ho un'idea
di dove appigliarmi per risolvere il problema che fa nascere sto' seven.

thanks!

mauro
unknown
2010-04-12 07:42:04 UTC
Permalink
Post by unknown
Dunque, prima mia figlia aveva W_XP e, con
//192.168.0.2/Condivisa /media/condivisa1 smbfs 0 0
nell'fstab, vedevo la sua cartella Condivisa.
Ora che lei e' passata a W_Seven, quando faccio
smbclient -L 192.168.0.2
che e' il suo indirizzo nella rete domestica, ottengo un
session setup failed: NT_STATUS_LOGON_FAILURE
mentre se lo faccio all'indirizzo del pc di mia moglie che ha ancora
W_XP, vedo le sue cartelle condivise e le posso utilizzare avendo messo
in fstab le righe giuste per poterle acquisire.
Mia figlia dice di non avere firewall attivati sul suo seven.
Qualcuno sa quale novita' sia comparsa in seven per impedire che vengano
lette le cartelle che seven mette in condivisione?
Da seven viene vista invece regolarmente una mia cartella che ho
condiviso, e la stampante collegata al mio pc, condivisa anch'essa.
Insomma, questo seven, che cacchio di casini ha instaurato nelle
connessioni di rete? Funziona tutto cosi' bene con XP, e non ho un'idea
di dove appigliarmi per risolvere il problema che fa nascere sto' seven.
thanks!
mauro
Credo che tu debba passargli le credenziali username e password. O comunque
controlla le impostazioni di condivisione su 7zozz.
--
Simo

- Registered Linux User #395060

- Software is like sex, it is better when it is free --> Linus B. Torvalds
-------------- parte successiva --------------
Un allegato HTML è stato rimosso...
URL: https://lists.ubuntu.com/archives/ubuntu-it/attachments/20100412/602deea7/attachment.htm
unknown
2010-04-12 09:50:14 UTC
Permalink
Post by unknown
Insomma, questo seven, che cacchio di casini ha instaurato nelle
connessioni di rete? Funziona tutto cosi' bene con XP, e non ho un'idea
di dove appigliarmi per risolvere il problema che fa nascere sto' seven.
in realta' non ha fatto nulla che inserire aggiornamenti di crittografia e
protocollo che samba ancora non ha aggiornato.

per risolverlo puoi smanazzare nel registry di windows7 e inserire questa voce:

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\LmCompatibilityLevel
impostando il campo a 2

questi un paio di link utili:

http://technet.microsoft.com/en-us/library/cc960646.aspx
http://www.sevenforums.com/network-sharing/30539-samba-shares-home-premium.html

--
Mauro Morichi
Nonsolocomputer s.r.l.
Roma
unknown
2010-04-12 10:14:11 UTC
Permalink
Post by unknown
HKLM\SYSTEM\CurrentControlSet\Control\Lsa\LmCompatibilityLevel
impostando il campo a 2
non credo sia il problema di Mauro.
La modifica suggerita dovrebbe servire a permettere ai client win 7 di
accedere a share su samba.

qui il problema è che da linux non si riesce ad accedere ad uno share su
win 7.

dato che con smbclient si ottiene un errore di 'logon_failure' prima
proverei con:

smbclient -L 192.168.0.2 password -U username -W workgroup

ed a passare successivamente anche le credenziali di user/pass montando
lo share.

se con smbclient si riesce a fare un list delle risorse condivise, ma
non si riesce a montare, allora potrebbe essere il caso di passare a
cifs come filesystem, invece dell'obsoleto smbs (questi problemi li ho
letti in rete, ma mai sperimentato personalmente):

mount -t cifs //ipaddress/sharefolder ~/Share/ -o username=username,\
password=password,iocharset=utf8,file_mode=0777,dir_mode=0777,rw

ciao
Max
unknown
2010-04-12 10:29:10 UTC
Permalink
ps.

se ancora non funzionasse, leggi questi post al paragrafo 'Windows 7
configuration':

http://ubuntuforums.org/showthread.php?t=1169149

infine, questi suggerimenti, in italiano :)

http://forum.ubuntu-it.org/index.php/topic,369051.msg2858611.html#msg2858611

(nell'ultimo post, il disinstallare il live id, non so quanto possa
servire, in ogni caso...)

ciao

Max
unknown
2010-04-13 12:29:16 UTC
Permalink
Grazie a tutti per le preziose informazioni. A tempo debito provvedero'
a mettere mano alle configurazioni. Spero di risolvere. Faro' sapere.

mauro
Post by unknown
ps.
se ancora non funzionasse, leggi questi post al paragrafo 'Windows 7
http://ubuntuforums.org/showthread.php?t=1169149
infine, questi suggerimenti, in italiano :)
http://forum.ubuntu-it.org/index.php/topic,369051.msg2858611.html#msg2858611
(nell'ultimo post, il disinstallare il live id, non so quanto possa
servire, in ogni caso...)
ciao
Max
Continue reading on narkive:
Loading...